support
Apr 20, 2018

Tip: keep the software up to date

2 comments

There were recent reports about SwitchBot not responding correctly to the commands issued via the mobile app: sometimes the arm swings at the first touch in the app, sometimes after 2-3 tries, and sometimes do not swing even after multiple tries.

We located the root cause and managed to improve the reliability to higher than 99.95% a few months ago.

In the past weeks, we received rare reports with similar issues, and all turned out as an outdated firmware.

 

Kindly keep your mobile app and firmware up to date, and make sure you enjoy the fun and convenience with SwitchBot.

 

SwitchBot is always at your service, as a simple switch to a smart home.

switchbot
Apr 20, 2018

Can you clarify how firmware is kept up to date, do I need to do this manually ?

support
Apr 23, 2018Edited: Apr 23, 2018

Hi,

SwitchBot's latest firmware version is V4.2 now.

When you turn into the settings page(by clicking the gear icon), it will automatically remind you to upgrade your firmware as the following picture shows.

 

New Posts
  • Lee TY
    a day ago

    Hi,there. I'm doubted that even this writings are written on your post :) On the feedback messanger, you guys asked me to upload my firmware info on my app and devices. And I sent you and waited for 4 days(2days if counting business days). Today, I got the message I didnt reply anything. Wow.... A week ago, I firstly post that your device doesn't recognize the basic timer and the things I've been replied are what is your firmware version? and ignoring messages...
  • Thierry Delabre
    3 days ago

    La télécommande freebox semble être une telecommande radio et non IR. Impossible de l’ajouter au hub ??
  • polar_moose
    5 days ago

    Was working until it tried to update firmware. Now it doesn't even light up. Have another hub that updated and works fine. When I go through the process, after turning from Auto to on it displays a white rectangle box with a blue dot with three dots in it. The bottom says start adding and it freezes there. Bluetooth is on, 2.4 network, and location premission given. Tried cord for working hub and no change. Cleared cache. Finally after freezing it adds a box to the home page with all my hubs and meters That say hub bootloader EC and if I click it it it says unable to connect, move closer. I pressed the reset button on the hub for about ten seconds while in the on position. Help.
logo-01_edited.png
0

About us

SwitchBot is your simple switch to a smart home. With easy set-up, we help you to create a comfortable home with innovative smart home products.

We believe a smart home should be simple and comfortable. With the mission of making your life simpler in the most accessible way, SwitchBot is dedicated to creating and crafting the most innovative smart home products for you.

Social

Subscribe to our email, follow us on social media, so you could get the best smart home product updates as soon as we have one.

  • Facebook
  • Twitter
  • Instagram
  • YouTube
© 2019 By Wonderlabs, Inc.