Tan Darren
Mar 7

Rasberry Pi3 and Switchbot

4 comments

Hi, I've purchased a switchbot recently and I am doing a project to allow my rasberry pi3 to communicate to the switchbot to press a button.

 

I've also tried cloning the github from https://github.com/OpenWonderLabs/python-host as mentioned in other forums however I am currently stuck at the run_command method. A series of steps that I've tried is that I've successfully paired and found the switchbot device, as well as connected to it. However the run_command line could not be executed and there are no error messages as well.

 

My raspberry pi comes with an in built bluetooth module and the switchbot firmware is currently at firmware 4.4

Tan Darren
Mar 11

I've managed to solved it by hard rebooting the switchbot via the hard reset button.

support
Mar 12

We are glad to hear that. Hope you have fun with SwitchBot.

Tan Darren
Mar 12

@support Hi can I check with you if the raspberry pi supports a password function. I've used the app to lock up my switchbot using a password however the code does not seem to allow me to have a password input to run my switchbot using a raspberry pi

support
Mar 14

@Tan Darren Password function is not included in the open API, and we don't have plan to release it for now. We suggest you use it without a password.

New Posts
  • Lee TY
    a day ago

    Hi,there. I'm doubted that even this writings are written on your post :) On the feedback messanger, you guys asked me to upload my firmware info on my app and devices. And I sent you and waited for 4 days(2days if counting business days). Today, I got the message I didnt reply anything. Wow.... A week ago, I firstly post that your device doesn't recognize the basic timer and the things I've been replied are what is your firmware version? and ignoring messages...
  • Thierry Delabre
    3 days ago

    La télécommande freebox semble être une telecommande radio et non IR. Impossible de l’ajouter au hub ??
  • polar_moose
    5 days ago

    Was working until it tried to update firmware. Now it doesn't even light up. Have another hub that updated and works fine. When I go through the process, after turning from Auto to on it displays a white rectangle box with a blue dot with three dots in it. The bottom says start adding and it freezes there. Bluetooth is on, 2.4 network, and location premission given. Tried cord for working hub and no change. Cleared cache. Finally after freezing it adds a box to the home page with all my hubs and meters That say hub bootloader EC and if I click it it it says unable to connect, move closer. I pressed the reset button on the hub for about ten seconds while in the on position. Help.
logo-01_edited.png
0

About us

SwitchBot is your simple switch to a smart home. With easy set-up, we help you to create a comfortable home with innovative smart home products.

We believe a smart home should be simple and comfortable. With the mission of making your life simpler in the most accessible way, SwitchBot is dedicated to creating and crafting the most innovative smart home products for you.

Social

Subscribe to our email, follow us on social media, so you could get the best smart home product updates as soon as we have one.

  • Facebook
  • Twitter
  • Instagram
  • YouTube
© 2019 By Wonderlabs, Inc.